0
Under review

Minimize and restore with mouse wheel and then the window unsnaps

ANOM 7 months ago • updated 4 months ago 3

Hi I think I found a bug and this is really annoying.


How to reproduce this bug:

1. turn minimize/restore with mouse wheel option on.

2. open a window.

3. aero snap the window to the left.

4. minimize and then restore with mouse wheel.

5. window is still snapped to the left.

6. unsnap the window.

7. repeat 4.

8. snap the window to the left again.

9. repeat 4.

10. now the window is restored AND UNSNAPPED.


Well this does not happen all the time, but it actually does.


I am still trying to find the exact condition this happens.


I experienced this mostly with IE and windows explorer window.


Any idea why this happens? Thanks.


p.s. This program is super great anyway.

Answer

Answer
Under review

I couldn't reproduce the issue. Even if I'll be able to reproduce it, I'm afraid that there's not much that I can do, as 7+ Taskbar Tweaker merely asks the system to minimize/restore the window, so it probably is a Windows issue.

You can try using a different tool, for example Task Manager, to minimize and restore your window. I guess that you'll see the same behavior.

Answer
Under review

I couldn't reproduce the issue. Even if I'll be able to reproduce it, I'm afraid that there's not much that I can do, as 7+ Taskbar Tweaker merely asks the system to minimize/restore the window, so it probably is a Windows issue.

You can try using a different tool, for example Task Manager, to minimize and restore your window. I guess that you'll see the same behavior.

well actually when I restore a window by clicking taskbar button, the window is still snapped. This only happens when I use mouse wheel to restore. I will try to find under what condition this happens.

I am experiencing this problem on three different computers and found under what condition this happens.


When I scroll the wheel up by just one step, the window restores okay. But when I do it quick, resulting in sending multiple wheel up signals, the window is unsnapped.


Currently I am bypassing this issue by using a simple autohotkey script to make the wheel scroll by just one step when mouse cursor is on the taskbar or thumbnails.


Hope this helps somebody.