0
Under review

Block double "switch to" in scroll

maxoku 1 week ago • updated 2 days ago 10

If used on maximized window that was minimized a double "switch to" command by double left click (rarely to occur) and double scroll up makes window restore (smaller window, not maximized) instead to be maximized like before.

This probably is a Windows bug or expected behavior, but could you block scroll to not to be used more that once that the double scroll behavior wouldn't happen at all?

Well, with double left click I could just probably add a shortcut and set it to 0, but there's no functions for the scroll.

Under review

I couldn't reproduce it. What I tried:

  • Open and maximize Notepad.
  • Minimize it.
  • Set "Middle click" to "Switch to".
  • Double click on the Notepad taskbar item with the middle mouse button. (1)
  • Minimize Notepad again.
  • Check "Minimize/restore when mouse is over: Taskbar buttons".
  • Restore Notepad by scrolling up aggressively. (2)

During my testing, in steps (1) and (2) (and in general) Notepad never became restored, only minimized or maximized.

That's strange. I had that even that on WinXP sometimes. Now I'm using Win8.1 and that was more offen with the left click. I could reproduce it wildly clicking on item. But I've set double left click to 0 and doesn't do that anymore.

Set "Middle click" to "Switch to".

I didn't say anything about middle click. Left mouse button already do it. Don't try to wildly press the middle button, cuz you can damage the mouse wheel.

Restore Notepad by scrolling up aggressively. (2)

Maybe try aggressively scroll down and up alternately. It probably won't happen immediately after first try. You need to do it for some time to occur. And when window became restored (not maximized) it stays that way, it won't maximize with that method so don't be afraid that you'd miss the moment and won't notice anything.

This bug is very annoying, cuz it might happen anytime, but if you want to reproduce it yourself it's not that easy lol.

Strange, but I still can do it with left button. Maybe for some reason if both commands "switch to" and "minimize" are mixed then they call another command "restore". But how it can be fixed?

What's your setup? How can I reproduce this?

There are no non-advanced options related to the left click. So please provide your relevant advanced options, and I'll see if I can reproduce it on my computer.

How can I send you my setup?

Well left click normally do "switch to" and when the window is active then it do "minimize". So that's the only explanation how this might happen. The same with scroll. Mouse scroll can be easily damage to sometimes scroll in opposite direction and some stuff.

Just tell me how you customized the left click. If you're saying that it happens without you customizing the left click, then it probably happens when the tweaker is not running, too. Is that right?

I tried to reproduce it with Notepad both with a click and a mouse wheel, both on Windows 8 and Windows 10. I couldn't reproduce this.

Were you aggressive enough? You need to be very quick and try for some time. I wouldn't test it on win10, they could fixed it there lol. And try File explorer maybe.

The same effect happens when some application is restoring windows and at the same time I'm restoring it with left click on toolbar button. E.g. I or other application open url to open in the browser and I click at that moment on Waterfox icon and then it's restored un-maximized.

I don't know what makes that. I had that also in WinXP, do it's certainly a Windows bug or feature.

I think that maybe lowering scroll sensitivity could help. If it would only accept one scroll and then block next ones for a second or two then it wouldn't happen.