Could not load library (5)

Micah Lindstrom 3 kuud tagasi uuendaja Michael (Ramen Software) 3 nädalat tagasi 10

I occasionally get this error and have to close and re-open 7+ Taskbar Tweaker for it to load properly. Not a dealbreaker by any means, just an occasional nuisance.

I'm using a portable install with a shortcut in %appdata%\Microsoft\Windows\Start Menu\Programs\Startup to get 7+ Taskbar Tweaker to run at startup. 


Oops, did not mean to post quite yet.

Note 7+ Taskbar Tweaker keeps running after I click "OK" on the error message, but all the icons are greyed out and I have to close 7+ Taskbar Tweaker from the system tray (next to the clock) and re-open it.

I only get this error on my computer startup. Therefore, I suspect 7+ Taskbar Tweaker is occasionally launching before the right system libraries have been loaded -- if you let the software retry after 5 or 10 seconds, I suspect it would succeed automatically without me having to manually restart the software.

Here's two screenshots -- the error message, and my settings. I don't think there's anything particularly unusual. Basically there's just one program the I don't want grouped in the taskbar, and that's the reason I'm using 7+ Taskbar Tweaker.


Hmm, maybe it's related to this error:


Are you using disable_taskbar_transparency? Are you using Open Shell, Classic Shell or a similar start menu customization tool?

I don't know what disable_taskbar_transparency is so I don't think I'm using it. I am definitely not using Open Shell, Classic Shell, or other start menu customization tool.

I am running Win10 version 2004 build 19041 on a work computer -- this is why I did the portable install with the Startup folder shortcut, instead of using the regular installer with the built-in "Run at startup" function.

Note if I re-open 7+ Taskbar Tweaker, it loads properly. So I don't think it's a fundamental incompatibility, I think the 7+ Taskbar Tweaker exe is occasionally getting triggered before certain Windows services or programs are loaded.


7+ Taskbar Tweaker has a mechanism to wait for the taskbar to initialize before it triggers the customization, so I don't think that's the problem. As it looks similar to the other error I linked, I have a solution in mind that might help. I'll try to implement it in a beta version and I'll let you know.

Hello, I found I can reproduce this exact same error and behavior when I restart Windows Explorer while 7+ Taskbar Tweaker is running. 7+ Taskbar Tweaker keeps running but with everything disabled until I manually close and re-open 7+ Taskbar Tweaker. 

0. Run the 7+ Taskbar Tweaker program as normal

1. Open File Explorer (to any folder) 

2. Open Windows Task Manager

3. (Open the full detailed view if needed)

4. Open the Processes tab and sort by Name

5. Under the Apps category, click Windows Explorer

6. In the bottom right, click Restart. (The button reads End Task for most processes, but Restart if you select Windows Explorer)

I can't reproduce it:


But it's good that you can. I'll try to change the code according to my guess regarding the issue, and I'll let you know when it's ready for you to check it on your computer.

Please try the new beta version, v5.12.3.5. You can get it here:


Let me know whether it fixes the problem.

Some good news and not-so-good news.

Not-so-good news -- I tried restarting Windows Explorer again with the non-beta version, and did NOT encounter the issue again. So I guess that's not 100% reproducible, not sure why.

Good news -- I installed the beta version and restarted Windows Explorer and saw no issues, and restarted my whole computer and saw no issues. So it may be resolved. I will post here again if I see the issue again, as it did happen intermittently anyway. 


Thanks for the update. I'll mark the issue as fixed once a new non-beta version is released. Let me know if you see it again.