The old 'could not load library' error, on Windows 10 21H1 2009

Mr K Smith 2 years ago updated by Michael (Ramen Software) 12 months ago 26

Thank you for your software.

On Windows 10 Pro - 21H1 (2009: 19043), the tweaker tells me: 'could not load library [. .] perhaps your Windows version is not supported'. I see that error message on every tweaker build that I have tried since (after) beta. Admittedly though I have not tried all of the intervening builds. I do not think that my Windows build is a particularly new one and indeed I think that I had the same problem on older builds on Windows. (Also, it would be handy were the tweaker's build number copyable from the window in which it displays.)



Fixed in v5.13.

Under review

There should be an error code after "could not load library", which code are you getting?

Please make sure that you're using the latest version of the tweaker, v5.12.3. If not, I'll try to understand what's going on by gathering more information.


My title contains typographical mistakes. I apologise. I cannot see how to fix those errors. The title should read as follows.

The old 'could not load library' error, on Windows 10 21H1 2009

I was indeed using version 5.12.3 of the tweaker. I am sorry for not providing the error code. That code is: 5. Screenshot.

I assume that explorer crashes when the tweaker launches, right? Can you create and upload a crash dump using ProcDump? Run procdump64.exe -mp -e explorer.exe and trigger the crash. The dump will be written to a file, the details will be printed in the ProcDump console window.

Thanks. I do not know whether the file explorer crashes. When the tweaker runs, automatically and post-installation, the tweaker window appears and something happens to my tray icons. To wit (er, I think): all non-system icons that were showing get moved to the 'hidden' section. In all other respects, so far as I have noticed, things work. Do you still want me to try to use ProcDump?

Yes, try it, it wouldn't hurt. From the code it seems like error 5 is supposed to happen only in case of a crash.

Other things to try:

  • If you have other customization programs, turn them off to check whether there's a conflict.
  • Try turning off all options (if they are disabled, you can temporarily use a portable version which will have all options turned off). If there's no error in this case, try to enable the options and find which option causes the error.

The problem seemed to disappear - but it has reappeared (problem '5' again) on Windows 21H2 (and I sent you an email about it, but perhaps instead I should have commented here).

I disabled the program 'Fences', by the company Stardock, ran ProcDump, and ran the tweaker. Here are the results.

ProcDump screen output:

[14:39:35] Exception: C0000005.ACCESS_VIOLATION
[14:39:36] Unhandled: C0000005.ACCESS_VIOLATION
[14:39:36] Dump 1 initiated: S:\procdump\explorer.exe_220101_143936.dmp
[14:39:37] Dump 1 complete: 71 MB written in 0.6 seconds
[14:39:37] Dump count reached.

ProcDump file output: here.

Adjusting settings, via the portable version: the portable version does not crash, even once the aforementioned Fences is running. I will try setting the portable version to auto-start, and rebooting . .

First I should say: the above anonymous comment is by me.

I find that the portable version works fine when run at boot. However, I should like to be able to run the installed version.

I looked at the dump. Something went wrong when setting up the initialization hook.

I haven't encountered this problem before, and it's tricky to understand what's going on from the dump because the dump doesn't contain executable sections.

I don't believe that the portable version or file permissions have any effect on this problem, it's more likely that you're just lucky and don't see this problem for now.

What I can do is send you a debug version of the tweaker which prints extra diagnostics. Perhaps it will allow me to understand what's the reason for this problem.

Solved - though the user might need to solve the problem herself, in that the new Windows build might be the cause of the problem. Also, the Explorer crash seems an ungraceful, unhelpful way to deal with the cause of the problem. I used the program Windows Repair to reset the file permissions of default items to default. After doing that, the installable version of the Tweaker worked fine!

'I don't believe that the portable version or file permissions have any effect on this problem, it's more likely that you're just lucky and don't see this problem for now.' You would seem to be right. For, I booted just now and saw the error again. Yes, please do send the debug version. (I am sorry for the late reply. For some reason - I will investigate - I seemed to receive no notification of your reply.)

Here's a debug version:


It prints some tracing on initialization and saves them to a log file in the installation folder. Please install it, and once you encounter the issue, send me the log. I have some idea for the reason of the crash, it can happen if one of the functions fail, but I don't know why it would fail.

I add that, at present and when run manually (as against on boot, which I have not tested with the portable version), the portable version continues to work without issue.

Thank you. It crashed as soon as run. Log.

Something very strange is going on there. The tweaker communicates with explorer and waits for a reply. The message goes through, but instead of a reply, the communication tears up early with an error. I have no explanation for this yet.

Here's a build with more logging. Please try it and attach its log, perhaps it can shed some light.


I had a bit of trouble getting the new version to crash. Perhaps the portable version was still running. (I need some version running - for, I cannot live without the Tweaker!) Anyhow, after installing it for a second time, it did crash. Log.

OK, so it looks like something in SetOptions might cause it.

Here's a new build with debug logs in SetOptions:


I also added a slight delay for more deterministic output, initialization might take about five seconds instead of being instant.

Interesting. It looks like the operations to apply the disable_taskbar_transparency advanced option cause this. That's probably why no other users reported about it - it's not a commonly used option, and not all users report about all problems.

Can you turn it off and see if that fixes the problem?

Yep: that seems to be it. I ran the 'debug 3' version of the tweaker (henceforth 'DB3'). It did not crash - but it does not crash every time. Then I disabled that option. Then did the following, none of which produced a crash: closed the program, re-ran it ('it' being DB3); closed and re-ran it again; closed it and reinstalled DB3, and ran DB3 again.


Great. I don't know why the issue happens, maybe an obscure Windows bug, but I changed the implementation such that the initialization should no longer be affected by it. You can update to v5.12.3.2 beta, please let me know if the issue occurs again.


Let me record here that the problem is indeed fixed. Well done!

Thanks for the follow up. I tried to get to the root cause, but didn't find the reason for the failure. I do suspect, though, that the issue only happens when the tweaker is used together with Open Shell/Classic Shell. Good to know the workaround I used works.


Fixed in v5.13.

'Fixed in v5.13.' Thank you for your work. However, I find that 5.13, which is the version that downloads from https://tweaker.ramensoftware.com/, generates the error 'taskbar not found'. Or at least it did the first time (not the second time) that I ran it.

Do you remember the exact error message? It should have mentioned an error code, which probably was 902, 903 or 904.

I don't think the issue was introduced in 5.13 since I didn't make changes around the relevant code, but I'd like to fix this. Please let me know if you find a way to reproduce the message. I also saw that you're using Stardock Fences and Open Shell, perhaps it happens due to a conflict with one of these tools.