+5

Taskbar hides on "Show desktop" when "disable_topmost" is enabled

RedIska 7 years ago updated by Horizon 7 years ago 9
First use of "Show desktop" after launch 7+ Taskbar Tweaker with enabled "Disable_topmost' removes taskbar, taskbar returns after action with taskbar, like Start menu that hides him or opening new window.
Win8.1
+1
Oh, after taskbar returns "Disable_topmost" function doesn't work.
Oh Yeah, "Same with me" means on Windows 7.

I could reproduce it. While this indeed looks a bit wrong, I'm not sure that it has a straightforward fix.
In general, if you want your window to not get minimized, you make it topmost, with is the exact opposite of what disable_topmost does.
See also: https://devblogs.microsoft.com/oldnewthing/20040527-00/?p=39153

May be temporarily return topmost flag while user presses 'Show desktop' button?
I prefer the first suggested solution more. With changing "Show Desktop" from CTRL+D to CTRL+M, there is the possibility there might be some windows that exist that are unminimizable – and therefore getting in the way of the button's functionality.
+1
Hmm, is there way to change function of 'Show Desktop' button to 'Minimize All'?
Would just like to add I have the same issue, Win7x64, v4.5.8. Been around for a while.
Same here, 4.5.10, Win 7 x64