+1
Fixed

"Combine grouped buttons" breaks when switching Windows 10 virtual desktops

Mixsynth 3 months ago • updated by RaMMicHaeL 1 month ago 6

Steps to reproduce:


1. Open 2 or more new windows of the same program

2. Under Windows Taskbar options, set "Combine taskbar buttons" option to "Never"; your windows should be shown as separate taskbar buttons

3. Under 7TT options, set "Combining" option to "Combine grouped buttons"; your windows should be combined under a single button

4. Hit WinKey+Tab and click "New desktop" at bottom right

5. If you a) hover over your previous desktop, b) click to switch back to your previous desktop or c) use WinKey+Ctrl+Left/Right to switch between desktops, your windows will no longer be combined

Answer

+1
Answer
Fixed

Fixed in 7+ Taskbar Tweaker v5.4.

+1

I could reproduce the issue. Unfortunately, the combining option implementation is rather complex, so there's no simple fix. I'll look at it one day, but it's not a priority.

+1
Started

Actually, it was simpler than I was afraid it would be. Should be fixed in 7+ Taskbar Tweaker v5.3.0.5 beta, please try it.

Yes – that's fixed it! Superb. Thank you.

Ah – there appears to be one unintended consequence. Now when you have "Combine taskbar buttons" set to "When taskbar is full" (under Taskbar settings) and "Combining" set to "Use taskbar settings (default)" (under 7TT settings), windows are still forcibly combined when you switch desktops.

+1

Good catch, thanks! Should be fixed in v5.3.0.6 beta.

+1
Answer
Fixed

Fixed in 7+ Taskbar Tweaker v5.4.